aboutsummaryrefslogtreecommitdiffstats
path: root/schmooz.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /schmooz.scm
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'schmooz.scm')
-rw-r--r--schmooz.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/schmooz.scm b/schmooz.scm
index 75ddfa7..39785f3 100644
--- a/schmooz.scm
+++ b/schmooz.scm
@@ -359,6 +359,15 @@
((not (and (char? chr) (not (char-whitespace? chr)))) str)
(read-char port)))
+(define (pathname->local-filename path)
+ (define vic (pathname->vicinity path))
+ (define plen (string-length path))
+ (let ((vlen (string-length vic)))
+ (if (and (substring? vic path)
+ (< vlen plen))
+ (in-vicinity (user-vicinity) (substring path vlen plen))
+ (slib:error 'pathname->local-filename path))))
+
;;;@ SCHMOOZ files.
(define schmooz
(let* ((scheme-file? (filename:match-ci?? "*??scm"))
@@ -400,9 +409,12 @@
(define sl (string-length file))
(cond ((texi-file? file) (schmooz-texi-file file))
((scheme-file? file)
- (schmooz-scm-file file (scm->txi file)))
+ (schmooz-scm-file
+ file (pathname->local-filename (scm->txi file))))
(else (schmooz-scm-file
- file (string-append file ".txi")))))
+ file
+ (pathname->local-filename
+ (string-append file ".txi"))))))
files))))
;;; SCHMOOZ-TOPS - schmooz top level forms.