aboutsummaryrefslogtreecommitdiffstats
path: root/schmooz.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /schmooz.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'schmooz.scm')
-rw-r--r--schmooz.scm34
1 files changed, 1 insertions, 33 deletions
diff --git a/schmooz.scm b/schmooz.scm
index 7bcab97..9755260 100644
--- a/schmooz.scm
+++ b/schmooz.scm
@@ -326,6 +326,7 @@
(substitute-macs bl mac-list))
body))
(out 0 "@end " (caddr ops))
+ (out 0)
(out 0)))
(define (schmooz-var defop name body xdefs)
@@ -358,39 +359,6 @@
((not (and (char? chr) (not (char-whitespace? chr)))) str)
(read-char port)))
-;;; Output files would be schmoozed
-(define schmooz-which-files
- (let* ((scheme-file? (filename:match-ci?? "*??scm"))
- (txi-file? (filename:match-ci?? "*??txi"))
- (texi-file? (let ((tex? (filename:match-ci?? "*??tex"))
- (texi? (filename:match-ci?? "*??texi")))
- (lambda (filename) (or (txi-file? filename)
- (tex? filename)
- (texi? filename)))))
- (txi->scm (filename:substitute?? "*txi" "*scm"))
- (scm->txi (filename:substitute?? "*scm" "*txi")))
- (define (schmooz-texi-file file)
- (call-with-input-file file
- (lambda (port)
- (do ((pos (find-string-from-port? "@include" port)
- (find-string-from-port? "@include" port)))
- ((not pos))
- (let ((fname #f))
- (cond ((not (eqv? 1 (fscanf port " %s" fname))))
- ((not (txi-file? fname)))
- ((not (file-exists? (txi->scm fname))))
- (else (display (txi->scm fname)) (display " "))))))))
- (lambda files
- (for-each (lambda (file)
- (define sl (string-length file))
- (cond ((texi-file? file) (schmooz-texi-file file))
- ((scheme-file? file)
- (schmooz-scm-file file (scm->txi file)))
- (else (schmooz-scm-file
- file (string-append file ".txi")))))
- files))))
-
-
;;;@ SCHMOOZ files.
(define schmooz
(let* ((scheme-file? (filename:match-ci?? "*??scm"))