aboutsummaryrefslogtreecommitdiffstats
path: root/scainit.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /scainit.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'scainit.scm')
-rw-r--r--scainit.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/scainit.scm b/scainit.scm
index 93fed1e..dd779e9 100644
--- a/scainit.scm
+++ b/scainit.scm
@@ -18,7 +18,7 @@
;;; 92/06/18
(require 'common-list-functions) ;to pick up EVERY
-(define syncase:andmap comlist:every)
+(define syncase:andmap every)
; In Chez Scheme "(syncase:void)" returns an object that is ignored by the
; REP loop. It is returned whenever a "nonspecified" value is specified
@@ -67,33 +67,34 @@
(define impl-error slib:error)
(define base:eval slib:eval)
+;@
(define syncase:eval base:eval)
(define macro:eval base:eval)
(define syncase:expand #f)
(define macro:expand #f)
+
(define (syncase:expand-install-hook expand)
(set! syncase:eval (lambda (x) (base:eval (expand x))))
(set! macro:eval syncase:eval)
(set! syncase:expand expand)
(set! macro:expand syncase:expand))
;;; We Need This for bootstrapping purposes:
+;@
(define (syncase:load <pathname>)
(slib:eval-load <pathname> syncase:eval))
(define macro:load syncase:load)
-
+;@
(define syncase:sanity-check #f)
+
;;; LOADING THE SYSTEM ITSELF:
-(let ((here (lambda (file)
- (in-vicinity (library-vicinity) file)))
- (scmhere (lambda (file)
- (in-vicinity (library-vicinity)
- (string-append file (scheme-file-suffix))))))
- (for-each (lambda (file) (slib:load (here file)))
- '("scaoutp"
- "scaglob"
- "scaexpp"))
+(slib:load (in-vicinity (program-vicinity) "scaoutp"))
+(slib:load (in-vicinity (program-vicinity) "scaglob"))
+(slib:load (in-vicinity (program-vicinity) "scaexpp"))
+
+(let ((scmhere (lambda (file)
+ (in-vicinity (library-vicinity) file))))
(syncase:expand-install-hook expand-syntax)
- (syncase:load (here "scamacr"))
+ (syncase:load (scmhere "scamacr"))
(set! syncase:sanity-check
(lambda ()
(syncase:load (scmhere "sca-exp"))