aboutsummaryrefslogtreecommitdiffstats
path: root/sc4opt.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /sc4opt.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'sc4opt.scm')
-rw-r--r--sc4opt.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/sc4opt.scm b/sc4opt.scm
index 8e92237..156ab92 100644
--- a/sc4opt.scm
+++ b/sc4opt.scm
@@ -8,7 +8,7 @@
;1. Any copy made of this software must include this copyright notice
;in full.
;
-;2. I have made no warrantee or representation that the operation of
+;2. I have made no warranty or representation that the operation of
;this software will be error-free, and I am under no obligation to
;provide any services, by way of maintenance, update, or otherwise.
;
@@ -23,30 +23,31 @@
;;; This code conforms to: William Clinger and Jonathan Rees, editors.
;;; Revised^4 Report on the Algorithmic Language Scheme.
+;@
(define (list-tail l p)
(if (< p 1) l (list-tail (cdr l) (- p 1))))
-
+;@
(define (string->list s)
(do ((i (- (string-length s) 1) (- i 1))
(l '() (cons (string-ref s i) l)))
((< i 0) l)))
-
+;@
(define (list->string l) (apply string l))
-
+;@
(define string-copy string-append)
-
+;@
(define (string-fill! s obj)
(do ((i (- (string-length s) 1) (- i 1)))
((< i 0))
(string-set! s i obj)))
-
+;@
(define (list->vector l) (apply vector l))
-
+;@
(define (vector->list s)
(do ((i (- (vector-length s) 1) (- i 1))
(l '() (cons (vector-ref s i) l)))
((< i 0) l)))
-
+;@
(define (vector-fill! s obj)
(do ((i (- (vector-length s) 1) (- i 1)))
((< i 0))