aboutsummaryrefslogtreecommitdiffstats
path: root/sc4opt.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /sc4opt.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'sc4opt.scm')
-rw-r--r--sc4opt.scm14
1 files changed, 0 insertions, 14 deletions
diff --git a/sc4opt.scm b/sc4opt.scm
index 156ab92..e3a7819 100644
--- a/sc4opt.scm
+++ b/sc4opt.scm
@@ -27,13 +27,6 @@
(define (list-tail l p)
(if (< p 1) l (list-tail (cdr l) (- p 1))))
;@
-(define (string->list s)
- (do ((i (- (string-length s) 1) (- i 1))
- (l '() (cons (string-ref s i) l)))
- ((< i 0) l)))
-;@
-(define (list->string l) (apply string l))
-;@
(define string-copy string-append)
;@
(define (string-fill! s obj)
@@ -41,13 +34,6 @@
((< i 0))
(string-set! s i obj)))
;@
-(define (list->vector l) (apply vector l))
-;@
-(define (vector->list s)
- (do ((i (- (vector-length s) 1) (- i 1))
- (l '() (cons (vector-ref s i) l)))
- ((< i 0) l)))
-;@
(define (vector-fill! s obj)
(do ((i (- (vector-length s) 1) (- i 1)))
((< i 0))