aboutsummaryrefslogtreecommitdiffstats
path: root/root.scm
diff options
context:
space:
mode:
authorJim Pick <jim@jimpick.com>1998-03-08 23:05:22 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commitb21cac3362022718634f7086964208b2eed8e897 (patch)
tree16f4b2e70645c0e8e2202023170b5a94baa967e3 /root.scm
parent3796d2595035e192ed4bf1c9a6bfdb13c3c9d261 (diff)
parentf24b9140d6f74804d5599ec225717d38ca443813 (diff)
downloadslib-b21cac3362022718634f7086964208b2eed8e897.tar.gz
slib-b21cac3362022718634f7086964208b2eed8e897.zip
Import Debian changes 2c0-3debian/2c0-3
slib (2c0-3) unstable; urgency=low * New maintainer. * slibconfig script to automatically configure guile. * Fix type in description, closes: Bug#18996 slib (2c0-2) unstable; urgency=low * Minor fix for debian/rules targets slib (2c0-1) unstable; urgency=low * New upstream source * New maintainer
Diffstat (limited to 'root.scm')
-rw-r--r--root.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/root.scm b/root.scm
index 5ba78c1..3c764a6 100644
--- a/root.scm
+++ b/root.scm
@@ -1,5 +1,5 @@
;;;"root.scm" Newton's and Laguerre's methods for finding roots.
-;Copyright (C) 1996 Aubrey Jaffer
+;Copyright (C) 1996, 1997 Aubrey Jaffer
;
;Permission to copy this software, to redistribute it, and to use it
;for any purpose is granted, subject to the following restrictions and
@@ -17,6 +17,8 @@
;promotional, or sales literature without prior written consent in
;each case.
+(require 'logical)
+
;;;; Newton's Method explained in:
;;; D. E. Knuth, "The Art of Computer Programming", Vol 2 /
;;; Seminumerical Algorithms, Reading Massachusetts, Addison-Wesley
@@ -95,7 +97,7 @@
(let* ((df (df/dz z))
(ddf (ddf/dz^2 z))
(disc (sqrt (- (* df df) (* fz ddf)))))
- (print 'disc disc)
+ ;;(print 'disc disc)
(if (zero? disc)
#f
(let* ((next-z
@@ -105,9 +107,9 @@
(imag-part disc))))
(- disc) disc))))
(next-delta-z (magnitude (- next-z z))))
- (print 'next-z next-z )
- (print '(f next-z) (f next-z))
- (print 'delta-z delta-z 'next-delta-z next-delta-z)
+ ;;(print 'next-z next-z )
+ ;;(print '(f next-z) (f next-z))
+ ;;(print 'delta-z delta-z 'next-delta-z next-delta-z)
(cond ((zero? next-delta-z) z)
((and delta-z (>= next-delta-z delta-z)) z)
(else