aboutsummaryrefslogtreecommitdiffstats
path: root/repl.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /repl.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'repl.scm')
-rw-r--r--repl.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/repl.scm b/repl.scm
index b7fff38..596f4d7 100644
--- a/repl.scm
+++ b/repl.scm
@@ -1,5 +1,5 @@
; "repl.scm", read-eval-print-loop for Scheme
-; Copyright (c) 1993, 2003 Aubrey Jaffer
+; Copyright (C) 1993, 2003 Aubrey Jaffer
;
;Permission to copy this software, to modify it, to redistribute it,
;to distribute modified versions, and to use it for any purpose is
@@ -46,12 +46,11 @@
(repl:load (lambda (<pathname>)
(call-with-input-file <pathname>
(lambda (port)
- (let ((old-load-pathname *load-pathname*))
- (set! *load-pathname* <pathname>)
- (do ((o (read port) (read port)))
- ((eof-object? o))
- (repl:eval o))
- (set! *load-pathname* old-load-pathname))))))
+ (with-load-pathname <pathname>
+ (lambda ()
+ (do ((o (read port) (read port)))
+ ((eof-object? o))
+ (repl:eval o))))))))
(repl:restart #f)
(has-char-ready? (provided? 'char-ready?))
(repl:error (lambda args (require 'debug) (apply qpn args)