aboutsummaryrefslogtreecommitdiffstats
path: root/recobj.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /recobj.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'recobj.scm')
-rw-r--r--recobj.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/recobj.scm b/recobj.scm
index 713f289..a634423 100644
--- a/recobj.scm
+++ b/recobj.scm
@@ -5,13 +5,14 @@
(require 'object)
(require 'common-list-functions)
-
+(define field:position position)
+;@
(define record-type-name (make-generic-method))
(define record-accessor (make-generic-method))
(define record-modifier (make-generic-method))
(define record? (make-generic-predicate))
(define record-constructor (make-generic-method))
-
+;@
(define (make-record-type type-name field-names)
(define self (make-object))
@@ -20,7 +21,7 @@
type-name))
(make-method! self record-accessor
(lambda (self field-name)
- (let ((index (comlist:position field-name field-names)))
+ (let ((index (field:position field-name field-names)))
(if (not index)
(slib:error "record-accessor: invalid field-name argument."
field-name))
@@ -29,7 +30,7 @@
(make-method! self record-modifier
(lambda (self field-name)
- (let ((index (comlist:position field-name field-names)))
+ (let ((index (field:position field-name field-names)))
(if (not index)
(slib:error "record-accessor: invalid field-name argument."
field-name))
@@ -54,4 +55,4 @@
self)
(provide 'record-object)
-(provide 'record) \ No newline at end of file
+(provide 'record)