aboutsummaryrefslogtreecommitdiffstats
path: root/rdms.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /rdms.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'rdms.scm')
-rw-r--r--rdms.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/rdms.scm b/rdms.scm
index eb74494..09506bc 100644
--- a/rdms.scm
+++ b/rdms.scm
@@ -17,6 +17,8 @@
;promotional, or sales literature without prior written consent in
;each case.
+(require 'rev4-optional-procedures) ;list-tail
+
(define rdms:catalog-name '*catalog-data*)
(define rdms:domains-name '*domains-data*)
(define rdms:columns-name '*columns*)
@@ -493,7 +495,6 @@
(let ((translate-column
(lambda (column)
- ;;(print 'translate-column column column-name-alist)
(let ((colp (assq column column-name-alist)))
(cond (colp (cdr colp))
((and (integer? column)
@@ -540,7 +541,7 @@
(norm-mkeys mkeys)))))
(else #f)))
(else
- (let ((index (- ci primary-limit 1))
+ (let ((index (- ci (+ primary-limit 1)))
(get-1 (base 'make-getter-1)))
(cond
(get-1
@@ -635,15 +636,16 @@
(define delete-table
(and mutable
(lambda (table-name)
- ;;(or rdms:catalog (set! rdms:catalog (open-table rdms:catalog-name #t)))
- (let* ((table (open-table table-name #t))
- (row ((rdms:catalog 'row:remove) table-name)))
- (and row (base:kill-table
- lldb
- (list-ref row (+ -1 catalog:bastab-id-pos))
- (table 'primary-limit)
- (table 'column-type-list))
- row)))))
+ (or rdms:catalog (set! rdms:catalog (open-table rdms:catalog-name #t)))
+ (and (table-exists? table-name)
+ (let ((table (open-table table-name #t))
+ (row ((rdms:catalog 'row:remove) table-name)))
+ (and row (base:kill-table
+ lldb
+ (list-ref row (+ -1 catalog:bastab-id-pos))
+ (table 'primary-limit)
+ (table 'column-type-list))
+ row))))))
(lambda (operation-name)
(case operation-name