aboutsummaryrefslogtreecommitdiffstats
path: root/randinex.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /randinex.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'randinex.txi')
-rw-r--r--randinex.txi6
1 files changed, 6 insertions, 0 deletions
diff --git a/randinex.txi b/randinex.txi
index b73f983..88dff74 100644
--- a/randinex.txi
+++ b/randinex.txi
@@ -10,6 +10,7 @@ Returns an uniformly distributed inexact real random number in the
range between 0 and 1.
@end defun
+
@defun random:exp
@@ -19,6 +20,7 @@ an exponential distribution with mean @var{u} use
@w{@code{(* @var{u} (random:exp))}}.
@end defun
+
@defun random:normal
@@ -29,6 +31,7 @@ standard deviation @var{d} use
@w{@code{(+ @var{m} (* @var{d} (random:normal)))}}.
@end defun
+
@deffn {Procedure} random:normal-vector! vect
@@ -37,6 +40,7 @@ Fills @var{vect} with inexact real random numbers which are independent
and standard normally distributed (i.e., with mean 0 and variance 1).
@end deffn
+
@deffn {Procedure} random:hollow-sphere! vect
@@ -47,6 +51,7 @@ of dimension n = @code{(vector-length @var{vect})}, the coordinates are
uniformly distributed over the surface of the unit n-shere.
@end deffn
+
@deffn {Procedure} random:solid-sphere! vect
@@ -57,3 +62,4 @@ space of dimension @var{n} = @code{(vector-length @var{vect})}, the
coordinates are uniformly distributed within the unit @var{n}-shere.
The sum of the squares of the numbers is returned.
@end deffn
+