aboutsummaryrefslogtreecommitdiffstats
path: root/queue.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /queue.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'queue.txi')
-rw-r--r--queue.txi9
1 files changed, 9 insertions, 0 deletions
diff --git a/queue.txi b/queue.txi
index 4590f34..efa6411 100644
--- a/queue.txi
+++ b/queue.txi
@@ -13,26 +13,31 @@ called @dfn{dequeues}). A queue may also be used like a stack.
Returns a new, empty queue.
@end defun
+
@defun queue? obj
Returns @code{#t} if @var{obj} is a queue.
@end defun
+
@defun queue-empty? q
Returns @code{#t} if the queue @var{q} is empty.
@end defun
+
@deffn {Procedure} queue-push! q datum
Adds @var{datum} to the front of queue @var{q}.
@end deffn
+
@deffn {Procedure} enqueue! q datum
Adds @var{datum} to the rear of queue @var{q}.
@end deffn
+
@deffn {Procedure} dequeue! q
@deffnx {Procedure} queue-pop! q
@@ -40,6 +45,7 @@ Both of these procedures remove and return the datum at the front of
the queue. @code{queue-pop!} is used to suggest that the queue is
being used like a stack.
@end deffn
+
All of the following functions raise an error if the queue @var{q}
is empty.
@@ -49,12 +55,15 @@ is empty.
Removes and returns (the list) of all contents of queue @var{q}.
@end deffn
+
@defun queue-front q
Returns the datum at the front of the queue @var{q}.
@end defun
+
@defun queue-rear q
Returns the datum at the rear of the queue @var{q}.
@end defun
+