aboutsummaryrefslogtreecommitdiffstats
path: root/psxtime.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /psxtime.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'psxtime.scm')
-rw-r--r--psxtime.scm40
1 files changed, 21 insertions, 19 deletions
diff --git a/psxtime.scm b/psxtime.scm
index 9d94b86..753e81f 100644
--- a/psxtime.scm
+++ b/psxtime.scm
@@ -8,7 +8,7 @@
;1. Any copy made of this software must include this copyright notice
;in full.
;
-;2. I have made no warrantee or representation that the operation of
+;2. I have made no warranty or representation that the operation of
;this software will be error-free, and I am under no obligation to
;provide any services, by way of maintenance, update, or otherwise.
;
@@ -19,6 +19,8 @@
;;; No, it doesn't do leap seconds.
+(require-if 'compiling 'time-zone)
+
(define time:days/month
'#(#(31 28 31 30 31 30 31 31 30 31 30 31) ; Normal years.
#(31 29 31 30 31 30 31 31 30 31 30 31)))
@@ -61,11 +63,11 @@
tm_gmtoff ; Seconds west of UTC.
tm_zone ; Timezone abbreviation.
)))))))))))
-
-(define (time:gmtime t)
+;@
+(define (gmtime t)
(time:split t 0 0 "GMT"))
-
-(define (time:localtime caltime . tz)
+;@
+(define (localtime caltime . tz)
(require 'time-zone)
(set! tz (if (null? tz) (tzset) (car tz)))
(apply time:split caltime (tz:params caltime tz)))
@@ -112,16 +114,16 @@
(loop guess
(+ 1 j)
(decoder guess))))))))))
-
-(define (time:mktime univtime . tz)
+;@
+(define (mktime univtime . tz)
(require 'time-zone)
(set! tz (if (null? tz) (tzset) (car tz)))
(+ (gmktime univtime) (tz:std-offset tz)))
-
-(define (time:gmktime univtime)
+;@
+(define (gmktime univtime)
(time:invert time:gmtime univtime))
-
-(define (time:asctime decoded)
+;@
+(define (asctime decoded)
(let ((days '#("Sun" "Mon" "Tue" "Wed" "Thu" "Fri" "Sat"))
(months '#("Jan" "Feb" "Mar" "Apr" "May" "Jun"
"Jul" "Aug" "Sep" "Oct" "Nov" "Dec"))
@@ -140,16 +142,16 @@
(number->2digits (vector-ref decoded 0) "0") " "
(number->string (+ 1900 (vector-ref decoded 5)))
(string #\newline))))
-
-(define (time:ctime . args)
+;@
+(define (ctime . args)
(time:asctime (apply time:localtime args)))
-
-(define (time:gtime time)
+;@
+(define (gtime time)
(time:asctime (time:gmtime time)))
;;; GMT Local -- take optional 2nd TZ arg
-(define gmtime time:gmtime) (define localtime time:localtime)
-(define gmktime time:gmktime) (define mktime time:mktime)
-(define gtime time:gtime) (define ctime time:ctime)
+(define time:gmtime gmtime) (define time:localtime localtime)
+;;(define time:gmktime gmktime) (define time:mktime mktime)
+;;(define time:gtime gtime) (define time:ctime ctime)
-(define asctime time:asctime)
+(define time:asctime asctime)