aboutsummaryrefslogtreecommitdiffstats
path: root/phil-spc.txi
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /phil-spc.txi
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'phil-spc.txi')
-rw-r--r--phil-spc.txi38
1 files changed, 38 insertions, 0 deletions
diff --git a/phil-spc.txi b/phil-spc.txi
new file mode 100644
index 0000000..1193c6c
--- /dev/null
+++ b/phil-spc.txi
@@ -0,0 +1,38 @@
+@code{(require 'hilbert-fill)}
+@ftindex hilbert-fill
+
+@noindent
+@cindex Peano
+@cindex Hilbert
+@cindex Space-Filling
+The @dfn{Peano-Hilbert Space-Filling Curve} is a one-to-one mapping
+@cindex Peano-Hilbert Space-Filling Curve
+between a unit line segment and an @var{n}-dimensional unit cube.
+
+@noindent
+The integer procedures map the non-negative integers to an
+arbitrarily large @var{n}-dimensional cube with its corner at the
+origin and all coordinates are non-negative.
+
+@noindent
+For any exact nonnegative integers @var{scalar} and @var{rank},
+
+@example
+(= @var{scalar} (hilbert-coordinates->integer
+ (integer->hilbert-coordinates @var{scalar} @var{rank})))
+ @result{} #t
+@end example
+
+
+@defun integer->hilbert-coordinates scalar rank
+
+Returns a list of @var{rank} integer coordinates corresponding to exact
+non-negative integer @var{scalar}. The lists returned by @code{integer->hilbert-coordinates} for @var{scalar} arguments
+0 and 1 will differ in the first element.
+@end defun
+
+@defun hilbert-coordinates->integer coords
+
+Returns an exact non-negative integer corresponding to @var{coords}, a list
+of non-negative integer coordinates.
+@end defun