aboutsummaryrefslogtreecommitdiffstats
path: root/peanosfc.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /peanosfc.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'peanosfc.txi')
-rw-r--r--peanosfc.txi15
1 files changed, 15 insertions, 0 deletions
diff --git a/peanosfc.txi b/peanosfc.txi
new file mode 100644
index 0000000..10cc256
--- /dev/null
+++ b/peanosfc.txi
@@ -0,0 +1,15 @@
+
+@defun integer->peano-coordinates scalar rank
+
+Returns a list of @var{rank} nonnegative integer coordinates corresponding
+to exact nonnegative integer @var{scalar}. The lists returned by @code{integer->peano-coordinates} for @var{scalar}
+arguments 0 and 1 will differ in the first element.
+@end defun
+
+
+@defun peano-coordinates->integer coords
+
+Returns an exact nonnegative integer corresponding to @var{coords}, a list of
+nonnegative integer coordinates.
+@end defun
+