aboutsummaryrefslogtreecommitdiffstats
path: root/ncbi-dna.txi
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /ncbi-dna.txi
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'ncbi-dna.txi')
-rw-r--r--ncbi-dna.txi54
1 files changed, 54 insertions, 0 deletions
diff --git a/ncbi-dna.txi b/ncbi-dna.txi
new file mode 100644
index 0000000..9a5babc
--- /dev/null
+++ b/ncbi-dna.txi
@@ -0,0 +1,54 @@
+
+@defun ncbi:read-dna-sequence port
+
+Reads the NCBI-format DNA sequence following the word @samp{ORIGIN}
+from @var{port}.
+@end defun
+
+@defun ncbi:read-file file
+
+Reads the NCBI-format DNA sequence following the word @samp{ORIGIN}
+from @var{file}.
+@end defun
+
+@defun mrna<-cdna str
+
+Replaces @samp{T} with @samp{U} in @var{str}
+@end defun
+
+@defun codons<-cdna cdna
+
+Returns a list of three-letter symbol codons comprising the protein
+sequence encoded by @var{cdna} starting with its first occurence of
+@samp{atg}.
+@end defun
+
+@defun protein<-cdna cdna
+
+Returns a list of three-letter symbols for the protein sequence
+encoded by @var{cdna} starting with its first occurence of @samp{atg}.
+@end defun
+
+@defun p<-cdna cdna
+
+Returns a string of one-letter amino acid codes for the protein
+sequence encoded by @var{cdna} starting with its first occurence of
+@samp{atg}.
+@end defun
+
+These cDNA count routines provide a means to check the nucleotide
+sequence with the @samp{BASE COUNT} line preceding the sequence from
+NCBI.
+
+
+@defun cdna:base-count cdna
+
+Returns a list of counts of @samp{a}, @samp{c}, @samp{g}, and
+@samp{t} occurrencing in @var{cdna}.
+@end defun
+
+@defun cdna:report-base-count cdna
+
+Prints the counts of @samp{a}, @samp{c}, @samp{g}, and @samp{t}
+occurrencing in @var{cdna}.
+@end defun