aboutsummaryrefslogtreecommitdiffstats
path: root/ncbi-dna.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /ncbi-dna.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'ncbi-dna.txi')
-rw-r--r--ncbi-dna.txi8
1 files changed, 8 insertions, 0 deletions
diff --git a/ncbi-dna.txi b/ncbi-dna.txi
index 9a5babc..160b9ee 100644
--- a/ncbi-dna.txi
+++ b/ncbi-dna.txi
@@ -5,17 +5,20 @@ Reads the NCBI-format DNA sequence following the word @samp{ORIGIN}
from @var{port}.
@end defun
+
@defun ncbi:read-file file
Reads the NCBI-format DNA sequence following the word @samp{ORIGIN}
from @var{file}.
@end defun
+
@defun mrna<-cdna str
Replaces @samp{T} with @samp{U} in @var{str}
@end defun
+
@defun codons<-cdna cdna
Returns a list of three-letter symbol codons comprising the protein
@@ -23,12 +26,14 @@ sequence encoded by @var{cdna} starting with its first occurence of
@samp{atg}.
@end defun
+
@defun protein<-cdna cdna
Returns a list of three-letter symbols for the protein sequence
encoded by @var{cdna} starting with its first occurence of @samp{atg}.
@end defun
+
@defun p<-cdna cdna
Returns a string of one-letter amino acid codes for the protein
@@ -36,6 +41,7 @@ sequence encoded by @var{cdna} starting with its first occurence of
@samp{atg}.
@end defun
+
These cDNA count routines provide a means to check the nucleotide
sequence with the @samp{BASE COUNT} line preceding the sequence from
NCBI.
@@ -47,8 +53,10 @@ Returns a list of counts of @samp{a}, @samp{c}, @samp{g}, and
@samp{t} occurrencing in @var{cdna}.
@end defun
+
@defun cdna:report-base-count cdna
Prints the counts of @samp{a}, @samp{c}, @samp{g}, and @samp{t}
occurrencing in @var{cdna}.
@end defun
+