aboutsummaryrefslogtreecommitdiffstats
path: root/mwsynrul.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /mwsynrul.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'mwsynrul.scm')
-rw-r--r--mwsynrul.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/mwsynrul.scm b/mwsynrul.scm
index bc5d7de..0ced293 100644
--- a/mwsynrul.scm
+++ b/mwsynrul.scm
@@ -72,7 +72,7 @@
(let ((literals (cadr spec))
(rules (cddr spec)))
(if (or (not (list? literals))
- (not (comlist:every (lambda (rule)
+ (not (mw:every (lambda (rule)
(and (= (mw:safe-length rule) 2)
(pair? (car rule))))
rules)))
@@ -115,7 +115,7 @@
(+ rank 1)
(lambda (P vars1)
(k (mw:make-ellipsis-pattern P vars1)
- (comlist:union vars1 vars))))
+ (mw:union vars1 vars))))
(mw:error "Malformed pattern" P))
(loop (car P)
vars
@@ -201,7 +201,7 @@
(lambda (T2 inserted referenced)
(k (cons (mw:make-ellipsis-template
T1
- (comlist:remove-if-not
+ (mw:remove-if-not
(lambda (var) (> (mw:patternvar-rank var)
rank))
referenced1))
@@ -259,7 +259,7 @@
(let* ((P1 (mw:ellipsis-pattern P))
(answers (map (lambda (F) (match F P1 answer rank))
F)))
- (if (comlist:every identity answers)
+ (if (mw:every identity answers)
(append (map (lambda (var)
(cons var
(map (lambda (answer)