aboutsummaryrefslogtreecommitdiffstats
path: root/modular.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /modular.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'modular.scm')
-rw-r--r--modular.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/modular.scm b/modular.scm
index e836100..052bf92 100644
--- a/modular.scm
+++ b/modular.scm
@@ -245,20 +245,18 @@
;;@args modulus n2 n3
;;Returns (@var{n2} ^ @var{n3}) mod @var{modulus}.
-(define modular:expt
- (let ((integer-expt (and (provided? 'inexact) expt)))
- (lambda (m n xpn)
- (cond ((= n 1) 1)
- ((= n (- m 1)) (if (odd? xpn) n 1))
- ((and (zero? m) integer-expt) (integer-expt n xpn))
- ((negative? xpn)
- (modular:expt m (modular:invert m n) (- xpn)))
- ((zero? n) 0)
- (else
- (do ((x n (modular:* m x x))
- (j xpn (quotient j 2))
- (acc 1 (if (even? j) acc (modular:* m x acc))))
- ((<= j 1)
- (case j
- ((0) acc)
- ((1) (modular:* m x acc))))))))))
+(define (modular:expt m n xpn)
+ (cond ((= n 1) 1)
+ ((= n (- m 1)) (if (odd? xpn) n 1))
+ ((zero? m) (expt n xpn))
+ ((negative? xpn)
+ (modular:expt m (modular:invert m n) (- xpn)))
+ ((zero? n) 0)
+ (else
+ (do ((x n (modular:* m x x))
+ (j xpn (quotient j 2))
+ (acc 1 (if (even? j) acc (modular:* m x acc))))
+ ((<= j 1)
+ (case j
+ ((0) acc)
+ ((1) (modular:* m x acc))))))))