aboutsummaryrefslogtreecommitdiffstats
path: root/mklibcat.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /mklibcat.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'mklibcat.scm')
-rw-r--r--mklibcat.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/mklibcat.scm b/mklibcat.scm
index d41e2e6..2047f86 100644
--- a/mklibcat.scm
+++ b/mklibcat.scm
@@ -71,6 +71,7 @@
(hash "hash")
(sierpinski "sierpinski")
(hilbert-fill "phil-spc")
+ (peano-fill "peanosfc")
(soundex "soundex")
(hash-table "hashtab")
(logical "logical")
@@ -137,6 +138,7 @@
(chapter-order "chap")
(posix-time "psxtime")
(common-lisp-time "cltime")
+ (time-core "timecore")
(time-zone defmacro "timezone")
(relational-database "rdms")
(databases "dbutil")
@@ -188,6 +190,7 @@
(color-database defmacro "mkclrnam")
(resene color-names "clrnamdb.scm")
(saturate color-names "clrnamdb.scm")
+ (nbs-iscc color-names "clrnamdb.scm")
(daylight "daylight")
(matfile "matfile")
(mat-file matfile)
@@ -208,6 +211,9 @@
(srfi-2 defmacro "srfi-2")
(srfi-8 macro "srfi-8")
(srfi-9 macro "srfi-9")
+ (srfi-47 array)
+ (srfi-63 array)
+ (srfi-60 logical)
(new-catalog "mklibcat")
))))
(let* ((req (in-vicinity (library-vicinity)