aboutsummaryrefslogtreecommitdiffstats
path: root/mkclrnam.txi
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /mkclrnam.txi
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'mkclrnam.txi')
-rw-r--r--mkclrnam.txi54
1 files changed, 54 insertions, 0 deletions
diff --git a/mkclrnam.txi b/mkclrnam.txi
new file mode 100644
index 0000000..3eeb892
--- /dev/null
+++ b/mkclrnam.txi
@@ -0,0 +1,54 @@
+@subsubheading Dictionary Creation
+
+@code{(require 'color-database)}
+@ftindex color-database
+
+
+@defun file->color-dictionary file table-name rdb base-table-type
+
+
+@defunx file->color-dictionary file table-name rdb
+
+@var{rdb} must be an open relational database or a string naming a relational
+database file, @var{table-name} a symbol, and the string @var{file} must name an existing
+file with colornames and their corresponding xRGB (6-digit hex)
+values. @code{file->color-dictionary} creates a table @var{table-name} in @var{rdb} and enters the associations found
+in @var{file} into it.
+@end defun
+
+@defun url->color-dictionary url table-name rdb base-table-type
+
+
+@defunx url->color-dictionary url table-name rdb
+
+@var{rdb} must be an open relational database or a string naming a relational
+database file and @var{table-name} a symbol. @code{url->color-dictionary} retrieves the resource named by the
+string @var{url} using the @dfn{wget} program; then calls
+@cindex wget
+@code{file->color-dictionary} to enter its associations in @var{table-name} in @var{url}.
+@end defun
+@noindent
+This section has detailed the procedures for creating and loading
+color dictionaries. So where are the dictionaries to load?
+
+@uref{http://swissnet.ai.mit.edu/~jaffer/Color/Dictionaries.html}
+
+@noindent
+Describes and evaluates several color-name dictionaries on the web.
+The following procedure creates a database containing two of these
+dictionaries.
+
+
+@defun make-slib-color-name-db
+
+Creates an @r{alist-table} relational database in @r{library-vicinity}
+containing the @dfn{Resene} and @dfn{saturate} color-name
+@cindex Resene
+@cindex saturate
+dictionaries.
+
+If the files @file{resenecolours.txt} and @file{saturate.txt} exist in
+the @r{library-vicinity}, then they used as the source of color-name
+data. Otherwise, @code{make-slib-color-name-db} calls url->color-dictionary with the URLs of
+appropriate source files.
+@end defun