aboutsummaryrefslogtreecommitdiffstats
path: root/mkclrnam.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /mkclrnam.scm
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'mkclrnam.scm')
-rw-r--r--mkclrnam.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/mkclrnam.scm b/mkclrnam.scm
index 47acd1a..341f6eb 100644
--- a/mkclrnam.scm
+++ b/mkclrnam.scm
@@ -1,5 +1,5 @@
;;; "mkclrnam.scm" create color name databases
-;Copyright 2001, 2002, 2003 Aubrey Jaffer
+;Copyright 2001, 2002, 2003, 2007 Aubrey Jaffer
;
;Permission to copy this software, to modify it, to redistribute it,
;to distribute modified versions, and to use it for any purpose is
@@ -95,6 +95,15 @@
(set! parse-rgb-line method))))))
(list
(lambda (line)
+ (define use #f)
+ (case (sscanf line "%[^;]; red=%d, green=%d, blue=%d; hex=%6x; %[^.].%s"
+ name r g b rgbx use junk)
+ ((6)
+ (set! method-id 'm6e)
+ (list (check-match line (xrgb->color rgbx) (color:sRGB r g b))
+ (color-name:canonicalize name)))
+ (else #f)))
+ (lambda (line)
(define en #f) (define fr #f) (define de #f)
(define es #f) (define cz #f) (define hu #f)
(case (sscanf line "#%6x %[^ ] %[^ ] %[^ ] %[^ ] %[^ ] %[^ ]%s"
@@ -153,7 +162,7 @@
(lambda (line)
(case (sscanf line "\" Resene %[^\"]\" %d %d %d %s"
name r g b junk)
- ((4) (set! method-id 'm4b)
+ ((4) (set! method-id 'm4d)
(list (check-match line (color:sRGB r g b))
(color-name:canonicalize name)))
(else #f)))
@@ -215,7 +224,7 @@
(set! *idx* (+ 1 *idx*))
(color-table:row-insert
(list name (car colin) *idx*)))
- (else (slib:warn 'collision name oclin)))))
+ (else (slib:warn 'collision colin oclin)))))
(cdr colin))))))))))
;;@noindent