aboutsummaryrefslogtreecommitdiffstats
path: root/manifest.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /manifest.scm
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'manifest.scm')
-rw-r--r--manifest.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/manifest.scm b/manifest.scm
index be55ea7..aa15e6e 100644
--- a/manifest.scm
+++ b/manifest.scm
@@ -332,10 +332,10 @@
(define (f2e feature)
(define path (cdr (or (assq feature catalog) '(#f . #f))))
(define (return path)
- (define path.scm (string-append path (scheme-file-suffix)))
- (cond ((file-exists? path.scm)
- (cons path.scm (file->exports path.scm)))
- (else (slib:warn 'feature->export-alist 'path? path.scm)
+ (define path_scm (string-append path (scheme-file-suffix)))
+ (cond ((file-exists? path_scm)
+ (cons path_scm (file->exports path_scm)))
+ (else (slib:warn 'feature->export-alist 'path? path_scm)
(list path))))
(cond ((not path) '())
((symbol? path) (f2e path))