aboutsummaryrefslogtreecommitdiffstats
path: root/logical.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /logical.scm
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'logical.scm')
-rw-r--r--logical.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/logical.scm b/logical.scm
index 5ea47f5..71e73b9 100644
--- a/logical.scm
+++ b/logical.scm
@@ -172,7 +172,7 @@
(else (intlen (logical:ash-4 n) (+ 4 tot)))))))
(lambda (n) (intlen n 0))))
;@
-(define logcount
+(define bitwise-bit-count
(letrec ((logcnt (lambda (n tot)
(if (zero? n)
tot
@@ -182,10 +182,14 @@
(modulo n 16))
tot))))))
(lambda (n)
- (cond ((negative? n) (logcnt (lognot n) 0))
+ (cond ((negative? n) (lognot (logcnt (lognot n) 0)))
((positive? n) (logcnt n 0))
(else 0)))))
;@
+(define (logcount n)
+ (cond ((negative? n) (bitwise-bit-count (lognot n)))
+ (else (bitwise-bit-count n))))
+;@
(define (log2-binary-factors n)
(+ -1 (integer-length (logand n (- n)))))