aboutsummaryrefslogtreecommitdiffstats
path: root/lineio.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /lineio.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'lineio.txi')
-rw-r--r--lineio.txi4
1 files changed, 4 insertions, 0 deletions
diff --git a/lineio.txi b/lineio.txi
index 22a1774..52d17b8 100644
--- a/lineio.txi
+++ b/lineio.txi
@@ -11,6 +11,7 @@ omitted, in which case it defaults to the value returned by
@code{current-input-port}.
@end defun
+
@deffn {Procedure} read-line! string
@@ -25,6 +26,7 @@ omitted, in which case it defaults to the value returned by
@code{current-input-port}.
@end deffn
+
@defun write-line string
@@ -35,6 +37,7 @@ which case it defaults to the value returned by
@code{current-input-port}.
@end defun
+
@defun system->line command tmp
@@ -44,3 +47,4 @@ a temporary file. @code{system->line} calls @code{system} with @var{command} as
redirecting stdout to file @var{tmp}. @code{system->line} returns a string containing the
first line of output from @var{tmp}.
@end defun
+