aboutsummaryrefslogtreecommitdiffstats
path: root/http-cgi.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /http-cgi.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'http-cgi.txi')
-rw-r--r--http-cgi.txi13
1 files changed, 10 insertions, 3 deletions
diff --git a/http-cgi.txi b/http-cgi.txi
index 67be216..0e57933 100644
--- a/http-cgi.txi
+++ b/http-cgi.txi
@@ -8,11 +8,13 @@ Returns a string containing lines for each element of @var{alist}; the
@code{car} of which is followed by @samp{: }, then the @code{cdr}.
@end defun
+
@defun http:content alist body @dots{}
Returns the concatenation of strings @var{body} with the
@code{(http:header @var{alist})} and the @samp{Content-Length} prepended.
@end defun
+
@defvar *http:byline*
String appearing at the bottom of error pages.
@end defvar
@@ -24,17 +26,19 @@ and any additional @var{html-strings} @dots{}; with @var{*http:byline*} or SLIB'
default at the bottom.
@end defun
-@defun http:forwarding-page title delay uri html-string @dots{}
-The string or symbol @var{title} is the page title. @var{delay} is a non-negative
+
+@defun http:forwarding-page title dly uri html-string @dots{}
+The string or symbol @var{title} is the page title. @var{dly} is a non-negative
integer. The @var{html-strings} @dots{} are typically used to explain to the user why
this page is being forwarded.
@code{http:forwarding-page} returns an HTML string for a page which automatically forwards to
-@var{uri} after @var{delay} seconds. The returned page (string) contains any @var{html-strings}
+@var{uri} after @var{dly} seconds. The returned page (string) contains any @var{html-strings}
@dots{} followed by a manual link to @var{uri}, in case the browser does not
forward automatically.
@end defun
+
@defun http:serve-query serve-proc input-port output-port
reads the @dfn{URI} and @dfn{query-string} from @var{input-port}. If the
@cindex URI
@@ -53,6 +57,7 @@ problem.
@end defun
+
This example services HTTP queries from @var{port-number}:
@example
@@ -93,6 +98,7 @@ Otherwise, @code{cgi:serve-query} replies (to @code{(current-input-port)}) with
appropriate HTML describing the problem.
@end defun
+
@defun make-query-alist-command-server rdb command-table
@@ -110,3 +116,4 @@ If optional third argument is non-false, then the command is called
with just the parameter-list; otherwise, command is called with the
arguments described in its table.
@end defun
+