aboutsummaryrefslogtreecommitdiffstats
path: root/http-cgi.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /http-cgi.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'http-cgi.scm')
-rw-r--r--http-cgi.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/http-cgi.scm b/http-cgi.scm
index 097da06..1dd1c07 100644
--- a/http-cgi.scm
+++ b/http-cgi.scm
@@ -47,7 +47,7 @@
(set! http:crlf (string (string-ref line 0) #\newline)))
(if (eof-object? line) line alist))
(let ((len (string-length line))
- (idx (strsrch:string-index line #\:)))
+ (idx (string-index line #\:)))
(if (char-whitespace? (string-ref line (+ -1 len)))
(set! len (+ -1 len)))
(and idx (do ((idx2 (+ idx 1) (+ idx2 1)))
@@ -68,9 +68,9 @@
(let* ((request-uri (cadr request-line))
(len (string-length request-uri)))
(and (> len 3)
- (strsrch:string-index request-uri #\?)
+ (string-index request-uri #\?)
(substring request-uri
- (+ 1 (strsrch:string-index request-uri #\?))
+ (+ 1 (string-index request-uri #\?))
(if (eqv? #\/ (string-ref request-uri (+ -1 len)))
(+ -1 len)
len)))))
@@ -125,7 +125,7 @@
*http:byline*
(sprintf
#f
- "<A HREF=http://swissnet.ai.mit.edu/~jaffer/SLIB.html>SLIB</A> %s server"
+ "<A HREF=http://swiss.csail.mit.edu/~jaffer/SLIB.html>SLIB</A> %s server"
(if (getenv "SERVER_PROTOCOL") "CGI/1.1" "HTTP/1.1"))))
(string-append (http:status-line status-code reason-phrase)
(http:content
@@ -143,9 +143,9 @@
;;@3 after @2 seconds. The returned page (string) contains any @4
;;@dots{} followed by a manual link to @3, in case the browser does not
;;forward automatically.
-(define (http:forwarding-page title delay uri . html-strings)
+(define (http:forwarding-page title dly uri . html-strings)
(string-append
- (html:head title #f (html:meta-refresh delay uri))
+ (html:head title #f (html:meta-refresh dly uri))
(apply html:body
(append html-strings
(list (sprintf #f "\\n\\n<HR>\\nReturn to %s.\\n"