aboutsummaryrefslogtreecommitdiffstats
path: root/htmlform.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /htmlform.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'htmlform.txi')
-rw-r--r--htmlform.txi24
1 files changed, 24 insertions, 0 deletions
diff --git a/htmlform.txi b/htmlform.txi
index e960984..77704ff 100644
--- a/htmlform.txi
+++ b/htmlform.txi
@@ -8,12 +8,14 @@ send @var{txt} as an @dfn{attribute-value}.
@cindex attribute-value
@end defun
+
@defun html:plain txt
Returns a string with character substitutions appropriate to
send @var{txt} as an @dfn{plain-text}.
@cindex plain-text
@end defun
+
@defun html:meta name content
Returns a tag of meta-information suitable for passing as the
third argument to @code{html:head}. The tag produced is @samp{<META
@@ -22,6 +24,7 @@ NAME="@var{name}" CONTENT="@var{content}">}. The string or symbol @var{name} ca
@samp{date}, @samp{robots}, @dots{}.
@end defun
+
@defun html:http-equiv name content
Returns a tag of HTTP information suitable for passing as the
third argument to @code{html:head}. The tag produced is @samp{<META
@@ -30,6 +33,7 @@ HTTP-EQUIV="@var{name}" CONTENT="@var{content}">}. The string or symbol @var{na
@samp{Refresh}, @dots{}.
@end defun
+
@defun html:meta-refresh delay uri
@@ -42,6 +46,7 @@ and display @var{uri}. Otherwise, @var{delay} seconds after displaying the page
this tag, Netscape or IE browsers will fetch and redisplay this page.
@end defun
+
@defun html:head title backlink tags @dots{}
@@ -55,10 +60,12 @@ used. If string arguments @var{tags} ... are supplied, then they are
included verbatim within the @t{<HEAD>} section.
@end defun
+
@defun html:body body @dots{}
Returns HTML string to end a page.
@end defun
+
@defun html:pre line1 line @dots{}
Returns the strings @var{line1}, @var{lines} as @dfn{PRE}formmated plain text
@cindex PRE
@@ -66,9 +73,11 @@ Returns the strings @var{line1}, @var{lines} as @dfn{PRE}formmated plain text
@var{lines}. HTML tags (@samp{<tag>}) within @var{lines} will be visible verbatim.
@end defun
+
@defun html:comment line1 line @dots{}
Returns the strings @var{line1} as HTML comments.
@end defun
+
@section HTML Forms
@@ -79,30 +88,37 @@ form. @code{html:form} returns the HTML @dfn{form}.
@cindex form
@end defun
+
@defun html:hidden name value
Returns HTML string which will cause @var{name}=@var{value} in form.
@end defun
+
@defun html:checkbox pname default
Returns HTML string for check box.
@end defun
+
@defun html:text pname default size @dots{}
Returns HTML string for one-line text box.
@end defun
+
@defun html:text-area pname default-list
Returns HTML string for multi-line text box.
@end defun
+
@defun html:select pname arity default-list foreign-values
Returns HTML string for pull-down menu selector.
@end defun
+
@defun html:buttons pname arity default-list foreign-values
Returns HTML string for any-of selector.
@end defun
+
@defun form:submit submit-label command
@@ -114,15 +130,18 @@ and @code{*button*=@var{submit-label}} are set in the query. Otherwise,
@code{*command*=@var{submit-label}} is set in the query.
@end defun
+
@defun form:image submit-label image-src
The @var{image-src} appears on the button which submits the form.
@end defun
+
@defun form:reset
Returns a string which generates a @dfn{reset} button.
@cindex reset
@end defun
+
@defun form:element pname arity default-list foreign-values
Returns a string which generates an INPUT element for the field
named @var{pname}. The element appears in the created form with its
@@ -160,6 +179,7 @@ text area
@end table
@end defun
+
@defun form:delimited pname doc aliat arity default-list foreign-values
@@ -168,15 +188,18 @@ delimited list. Apply map @code{form:delimited} to the list returned by
@code{command->p-specs}.
@end defun
+
@defun html:delimited-list row @dots{}
Wraps its arguments with delimited-list (@samp{DL} command.
@end defun
+
@defun get-foreign-choices tab
Returns a list of the @samp{visible-name} or first fields of
table @var{tab}.
@end defun
+
@defun command->p-specs rdb command-table command
@@ -212,3 +235,4 @@ command.
port)))
@end example
@end defun
+