aboutsummaryrefslogtreecommitdiffstats
path: root/html4each.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /html4each.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'html4each.scm')
-rw-r--r--html4each.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/html4each.scm b/html4each.scm
index 02e666e..f115616 100644
--- a/html4each.scm
+++ b/html4each.scm
@@ -225,16 +225,28 @@
(reverse fields))
((eqv? #\> chr) (cons element (reverse fields)))
((char-whitespace? chr) (read-char port) (loop (peek-char port)))
- ((case (fscanf port "%[a-zA-Z0-9]%[=]%[-.a-zA-Z0-9]" name junk value)
+ ((case (fscanf port "%[a-zA-Z0-9]%[=]%[-.a-zA-Z0-9]"
+ name junk value)
((3 1) #t)
((2)
(case (peek-char port)
- ((#\") (eqv? 1 (fscanf port "\"%[^\"]\"" value)))
- ((#\') (eqv? 1 (fscanf port "'%[^']'" value)))
+ ((#\") (cond ((eqv? 1 (fscanf port "\"%[^\"]\"" value)))
+ ((eqv? #\" (peek-char port))
+ (read-char port)
+ (set! value ""))
+ (else #f)))
+ ((#\') (cond ((eqv? 1 (fscanf port "'%[^']'" value)))
+ ((eqv? #\' (peek-char port))
+ (read-char port)
+ (set! value ""))
+ (else #f)))
(else #f)))
(else #f))
(set! fields (cons (cons (string-ci->symbol name)
- (or (string->number value) value))
+ (if (string? value)
+ (or (string->number value) value)
+ value))
fields))
(loop (peek-char port)))
- (else (slib:warn 'htm-fields 'bad 'field htm) (reverse fields))))))))
+ (else (slib:warn 'htm-fields 'bad 'field htm)
+ (reverse fields))))))))