aboutsummaryrefslogtreecommitdiffstats
path: root/hashtab.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /hashtab.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'hashtab.txi')
-rw-r--r--hashtab.txi9
1 files changed, 9 insertions, 0 deletions
diff --git a/hashtab.txi b/hashtab.txi
index b2a7a0e..572b452 100644
--- a/hashtab.txi
+++ b/hashtab.txi
@@ -10,6 +10,7 @@ Returns a hash function (like @code{hashq}, @code{hashv}, or
@code{char=?}, @code{char-ci=?}, @code{string=?}, or
@code{string-ci=?}.
@end defun
+
@noindent
A hash table is a vector of association lists.
@@ -18,6 +19,7 @@ A hash table is a vector of association lists.
Returns a vector of @var{k} empty (association) lists.
@end defun
+
@noindent
Hash table functions provide utilities for an associative database.
These functions take an equality predicate, @var{pred}, as an argument.
@@ -35,6 +37,7 @@ argument or @code{#f} if no key in @var{hashtab} is @var{pred}-equal to
the first argument.
@end defun
+
@defun hash-inquirer pred
Returns a procedure of 2 arguments, @var{hashtab} and @var{key}, which
@@ -42,6 +45,7 @@ returns the value associated with @var{key} in @var{hashtab} or
@code{#f} if @var{key} does not appear in @var{hashtab}.
@end defun
+
@defun hash-associator pred
Returns a procedure of 3 arguments, @var{hashtab}, @var{key}, and
@@ -50,6 +54,7 @@ Returns a procedure of 3 arguments, @var{hashtab}, @var{key}, and
will be lost.
@end defun
+
@defun hash-remover pred
Returns a procedure of 2 arguments, @var{hashtab} and @var{key}, which
@@ -57,6 +62,7 @@ modifies @var{hashtab} so that the association whose key is @var{key} is
removed.
@end defun
+
@defun hash-map proc hash-table
Returns a new hash table formed by mapping @var{proc} over the
@@ -64,6 +70,7 @@ keys and values of @var{hash-table}. @var{proc} must be a function of 2
arguments which returns the new value part.
@end defun
+
@defun hash-for-each proc hash-table
Applies @var{proc} to each pair of keys and values of @var{hash-table}.
@@ -71,6 +78,7 @@ Applies @var{proc} to each pair of keys and values of @var{hash-table}.
unspecified.
@end defun
+
@defun hash-rehasher pred
@code{hash-rehasher} accepts a hash table predicate and returns a function of two
@@ -82,3 +90,4 @@ This function is used for nondestrutively resizing a hash table.
is the size of a new hash table to be returned. The new hash table
will have all of the associations of the old hash table.
@end defun
+