aboutsummaryrefslogtreecommitdiffstats
path: root/glob.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /glob.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'glob.txi')
-rw-r--r--glob.txi4
1 files changed, 4 insertions, 0 deletions
diff --git a/glob.txi b/glob.txi
index d83b66b..c2a27bb 100644
--- a/glob.txi
+++ b/glob.txi
@@ -32,6 +32,7 @@ matched by including it as the first or last character in the set.
@end table
@end defun
+
@defun filename:substitute?? pattern template
@defunx filename:substitute-ci?? pattern template
@@ -53,6 +54,7 @@ the case of a match the result of applying @var{template} to a list
of the substrings matched by wildcard specifications will be returned,
otherwise @var{template} will not be called and @code{#f} will be returned.
@end defun
+
@example
((filename:substitute?? "scm_[0-9]*.html" "scm5c4_??.htm")
"scm_10.html")
@@ -74,6 +76,7 @@ otherwise @var{template} will not be called and @code{#f} will be returned.
removed and the suffix string @var{new} appended. If the end of
@var{str} does not match @var{old}, an error is signaled.
@end defun
+
@example
(replace-suffix "/usr/local/lib/slib/batch.scm" ".scm" ".c")
@result{} "/usr/local/lib/slib/batch.c"
@@ -98,3 +101,4 @@ If @var{proc} returns, then any files named by the arguments to @var{proc} are
deleted automatically and the value(s) yielded by the @var{proc} is(are)
returned.
@end defun
+