aboutsummaryrefslogtreecommitdiffstats
path: root/formatst.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /formatst.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'formatst.scm')
-rw-r--r--formatst.scm44
1 files changed, 16 insertions, 28 deletions
diff --git a/formatst.scm b/formatst.scm
index 77a46c4..28d656a 100644
--- a/formatst.scm
+++ b/formatst.scm
@@ -19,7 +19,8 @@
; to string-downcase.
(require 'format)
-(if (not (string=? format:version "3.0"))
+
+(if (not (string=? format:version "3.1"))
(begin
(display "You have format version ")
(display format:version)
@@ -63,11 +64,10 @@
; ensure format default configuration
-(set! format:symbol-case-conv #f)
-(set! format:iobj-case-conv #f)
-(set! format:read-proof #f)
-(set! format:iteration-bounded #t)
-(set! format:max-iterations 100)
+;;(set! format:symbol-case-conv #f)
+;;(set! format:iobj-case-conv #f)
+;;(set! format:iteration-bounded #t)
+;;(set! format:max-iterations 100)
(format #t "~q")
@@ -91,9 +91,9 @@
(test '("~a" (a (b c) d)) "(a (b c) d)")
(test '("~a" (a . b)) "(a . b)")
(test '("~a" (a (b c . d))) "(a (b . (c . d)))") ; this is ugly
-(test `("~a" ,display) (format:iobj->str display))
-(test `("~a" ,(current-input-port)) (format:iobj->str (current-input-port)))
-(test `("~a" ,(current-output-port)) (format:iobj->str (current-output-port)))
+(test `("~a" ,display) (format:iobj->str display #f))
+(test `("~a" ,(current-input-port)) (format:iobj->str (current-input-port) #f))
+(test `("~a" ,(current-output-port)) (format:iobj->str (current-output-port) #f))
; # argument test
@@ -313,29 +313,19 @@ def")
; read proof test
-(test `("~:s" ,display)
- (begin
- (set! format:read-proof #t)
- (format:iobj->str display)))
-(test `("~:a" ,display)
- (begin
- (set! format:read-proof #t)
- (format:iobj->str display)))
-(test `("~:a" (1 2 ,display))
- (begin
- (set! format:read-proof #t)
- (string-append "(1 2 " (format:iobj->str display) ")")))
+(test `("~:s" ,display) (format:iobj->str display #t))
+(test `("~:a" ,display) (format:iobj->str display #t))
+(test `("~:a" (1 2 ,display)) (string-append "(1 2 " (format:iobj->str display #t) ")"))
(test '("~:a" "abc") "abc")
-(set! format:read-proof #f)
; internal object case type force test
(set! format:iobj-case-conv string-upcase)
-(test `("~a" ,display) (string-upcase (format:iobj->str display)))
+(test `("~a" ,display) (string-upcase (format:iobj->str display #f)))
(set! format:iobj-case-conv string-downcase)
-(test `("~s" ,display) (string-downcase (format:iobj->str display)))
+(test `("~s" ,display) (string-downcase (format:iobj->str display #f)))
(set! format:iobj-case-conv string-capitalize)
-(test `("~s" ,display) (string-capitalize (format:iobj->str display)))
+(test `("~s" ,display) (string-capitalize (format:iobj->str display #f)))
(set! format:iobj-case-conv #f)
; continuation line test
@@ -366,7 +356,7 @@ def")
(test '("~:@(~a~)" (a b c)) "(A B C)")
(test '("~:@(~x~)" 255) "FF")
(test '("~:@(~p~)" 2) "S")
-(test `("~:@(~a~)" ,display) (string-upcase (format:iobj->str display)))
+(test `("~:@(~a~)" ,display) (string-upcase (format:iobj->str display #f)))
(test '("~:(~a ~a ~a~) ~a" "abc" "xyz" "123" "world") "Abc Xyz 123 world")
; variable parameter
@@ -662,5 +652,3 @@ def")
(if (not test-verbose) (display "done."))
(format #t "~%~a Test~:p completed. (~a failure~:p)~2%" total fails)
-
-; eof