aboutsummaryrefslogtreecommitdiffstats
path: root/fft.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /fft.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'fft.scm')
-rw-r--r--fft.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/fft.scm b/fft.scm
index 2257e30..feefec8 100644
--- a/fft.scm
+++ b/fft.scm
@@ -39,7 +39,7 @@
(slib:error 'fft "array length not power of 2" n))
(do ((k 0 (+ 1 k)))
((>= k n) new)
- (array-set! new (* (array-ref ara k) scale) (bit-reverse lgn k))))
+ (array-set! new (* (array-ref ara k) scale) (reverse-bit-field k 0 lgn))))
(define (dft! ara n dir)
(define lgn (integer-length (+ -1 n)))
@@ -66,7 +66,7 @@
;;@dfn{Discrete Fourier Transform} of @var{array}.
(define (fft ara)
(define n (car (array-dimensions ara)))
- (define new (apply create-array ara (array-dimensions ara)))
+ (define new (apply make-array ara (array-dimensions ara)))
(dft! (fft:shuffle&scale new ara n 1) n 1))
;;@args array
@@ -74,7 +74,7 @@
;;inverse Discrete Fourier Transform of @var{array}.
(define (fft-1 ara)
(define n (car (array-dimensions ara)))
- (define new (apply create-array ara (array-dimensions ara)))
+ (define new (apply make-array ara (array-dimensions ara)))
(dft! (fft:shuffle&scale new ara n (/ n)) n -1))
;;@noindent