aboutsummaryrefslogtreecommitdiffstats
path: root/factor.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /factor.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'factor.txi')
-rw-r--r--factor.txi5
1 files changed, 5 insertions, 0 deletions
diff --git a/factor.txi b/factor.txi
index 38c0dd1..90569ea 100644
--- a/factor.txi
+++ b/factor.txi
@@ -22,6 +22,7 @@ Returns the value (+1, @minus{}1, or 0) of the Jacobi-Symbol of
exact non-negative integer @var{p} and exact positive odd integer @var{q}.
@end defun
+
@defvar prime:trials
@var{prime:trials} the maxinum number of iterations of Solovay-Strassen that will
@@ -35,6 +36,7 @@ There is a slight chance @code{(expt 2 (- prime:trials))} that a
composite will return @code{#t}.
@end defun
+
@defun primes< start count
Returns a list of the first @var{count} prime numbers less than
@@ -43,14 +45,17 @@ less than @var{start}, then the returned list will have fewer than
@var{start} elements.
@end defun
+
@defun primes> start count
Returns a list of the first @var{count} prime numbers greater than @var{start}.
@end defun
+
@defun factor k
Returns a list of the prime factors of @var{k}. The order of the
factors is unspecified. In order to obtain a sorted list do
@code{(sort! (factor @var{k}) <)}.
@end defun
+