aboutsummaryrefslogtreecommitdiffstats
path: root/dirs.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /dirs.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'dirs.txi')
-rw-r--r--dirs.txi3
1 files changed, 3 insertions, 0 deletions
diff --git a/dirs.txi b/dirs.txi
index 65d8b24..3542374 100644
--- a/dirs.txi
+++ b/dirs.txi
@@ -11,12 +11,14 @@ cannot be obtained, #f is returned.
If @code{current-directory} cannot be supported by the platform, then #f is returned.
@end defun
+
@defun make-directory name
Creates a sub-directory @var{name} of the current-directory. If
successful, @code{make-directory} returns #t; otherwise #f.
@end defun
+
@defun directory-for-each proc directory
@var{proc} must be a procedure taking one argument.
@@ -44,3 +46,4 @@ Applies @var{proc} only to those filenames for which
"Template.scm"
@end example
@end defun
+