aboutsummaryrefslogtreecommitdiffstats
path: root/dirs.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /dirs.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'dirs.scm')
-rw-r--r--dirs.scm98
1 files changed, 98 insertions, 0 deletions
diff --git a/dirs.scm b/dirs.scm
new file mode 100644
index 0000000..0592021
--- /dev/null
+++ b/dirs.scm
@@ -0,0 +1,98 @@
+;;; "dirs.scm" Directories.
+; Copyright 1998, 2002 Aubrey Jaffer
+;
+;Permission to copy this software, to modify it, to redistribute it,
+;to distribute modified versions, and to use it for any purpose is
+;granted, subject to the following restrictions and understandings.
+;
+;1. Any copy made of this software must include this copyright notice
+;in full.
+;
+;2. I have made no warranty or representation that the operation of
+;this software will be error-free, and I am under no obligation to
+;provide any services, by way of maintenance, update, or otherwise.
+;
+;3. In conjunction with products arising from the use of this
+;material, there shall be no use of my name in any advertising,
+;promotional, or sales literature without prior written consent in
+;each case.
+
+(require 'filename)
+(require 'line-i/o)
+(require 'system)
+(require 'glob)
+
+;;@code{(require 'directory)}
+;;@ftindex directory
+
+;;@args
+;;@0 returns a string containing the absolute file
+;;name representing the current working directory. If this string
+;;cannot be obtained, #f is returned.
+;;
+;;If @0 cannot be supported by the platform, then #f is returned.
+(define current-directory
+ (case (software-type)
+ ;;((AMIGA) )
+ ;;((MACOS THINKC) )
+ ((MS-DOS WINDOWS ATARIST OS/2) (lambda () (system->line "cd")))
+ ;;((NOSVE) )
+ ((UNIX COHERENT PLAN9) (lambda () (system->line "pwd")))
+ ;;((VMS) )
+ (else #f)))
+
+;;@body
+;;Creates a sub-directory @1 of the current-directory. If
+;;successful, @0 returns #t; otherwise #f.
+(define (make-directory name)
+ (eqv? 0 (system (string-append "mkdir \"" name "\""))))
+
+(define (dir:lister dirname tmp)
+ (case (software-type)
+ ((UNIX COHERENT PLAN9)
+ (zero? (system (string-append "ls '" dirname "' > " tmp))))
+ ((MS-DOS WINDOWS OS/2 ATARIST)
+ (zero? (system (string-append "DIR /B \"" dirname "\" > " tmp))))
+ (else (slib:error (software-type) 'list?))))
+
+;;@args proc directory
+;;@var{proc} must be a procedure taking one argument.
+;;@samp{Directory-For-Each} applies @var{proc} to the (string) name of
+;;each file in @var{directory}. The dynamic order in which @var{proc} is
+;;applied to the filenames is unspecified. The value returned by
+;;@samp{directory-for-each} is unspecified.
+;;
+;;@args proc directory pred
+;;Applies @var{proc} only to those filenames for which the procedure
+;;@var{pred} returns a non-false value.
+;;
+;;@args proc directory match
+;;Applies @var{proc} only to those filenames for which
+;;@code{(filename:match?? @var{match})} would return a non-false value
+;;(@pxref{Filenames, , , slib, SLIB}).
+;;
+;;@example
+;;(require 'directory)
+;;(directory-for-each print "." "[A-Z]*.scm")
+;;@print{}
+;;"Bev2slib.scm"
+;;"Template.scm"
+;;@end example
+(define (directory-for-each proc dirname . args)
+ (define selector
+ (cond ((null? args) identity)
+ ((> (length args) 1)
+ (slib:error 'directory-for-each 'too-many-arguments (cdr args)))
+ ((procedure? (car args)) (car args))
+ ((string? (car args)) (filename:match?? (car args)))
+ (else
+ (slib:error 'directory-for-each 'filter? (car args)))))
+ (call-with-tmpnam
+ (lambda (tmp)
+ (and (dir:lister dirname tmp)
+ (file-exists? tmp)
+ (call-with-input-file tmp
+ (lambda (port)
+ (do ((filename (read-line port) (read-line port)))
+ ((or (eof-object? filename) (equal? "" filename)))
+ (and (selector filename) (proc filename)))))))))