aboutsummaryrefslogtreecommitdiffstats
path: root/debian/postinst
diff options
context:
space:
mode:
authorJari Aalto <jari.aalto@cante.net>2010-05-05 03:13:42 +0300
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:43 -0800
commit61af55884cfcb2ac70f42a9fc8dc68b3c343b402 (patch)
tree7159ecad56e23911f4c869d2f2e076c382378157 /debian/postinst
parent3f111dfa0c6ef68339f1a5086342a53a66a4c57a (diff)
downloadslib-61af55884cfcb2ac70f42a9fc8dc68b3c343b402.tar.gz
slib-61af55884cfcb2ac70f42a9fc8dc68b3c343b402.zip
Import Debian changes 3b1-3.1debian/3b1-3.1
slib (3b1-3.1) unstable; urgency=low [ Jari Aalto ] * Non-maintainer upload. - Move to packaging format "3.0 (quilt)". * debian/compat - Update to 7. * debian/control - (Build-Depends-Indep): Update to debhelper 7.1. - (Depends): add ${misc:Depends}. - (Homepage): New field. - (Standards-Version): update to 3.8.4. + slib - (Depends): add ${misc:Depends}, install-info. - (Priority): remove inherited field. - (Section): remove inherited field. * debian/copyright - Update "more information" URL. * debian/doc-base - (Section): Remove obsolete top-level "Apps/". * debian/prerm - Remove path component from commands. - Remove obsolete install-docs, install-info commands. * debian/postinst - Remove obsolete install-docs, install-info commands. - Remove path component from commands. * debian/source/format - New file. * debian/watch - New file. [ Hideki Yamane (Debian-JP) <henrich@debian.or.jp> ] * debian/rules - (build): Rewrite make calls. - (binary-indep:): install *.html not slib/*.html to fix. It is useless to specify htmllib (FTBFS; Closes: #552911).
Diffstat (limited to 'debian/postinst')
-rwxr-xr-x[-rw-r--r--]debian/postinst25
1 files changed, 9 insertions, 16 deletions
diff --git a/debian/postinst b/debian/postinst
index ea573b7..b88e923 100644..100755
--- a/debian/postinst
+++ b/debian/postinst
@@ -1,23 +1,22 @@
#!/bin/sh
-set -e
-install-info --quiet --section "The Algorithmic Language Scheme" \
- "The Algorithmic Language Scheme" \
- --description="The SLIB portable Scheme library" \
- /usr/share/info/slib.info.gz
+set -e
# OK. This is bad because it really should be in the guile config or
# in some emacs-common sort of package. Now we conditionally run it.
# one of these probably shouldn't exist, but don't know which and
# probably should support the older.
+
if [ -x /usr/sbin/guile1.4-slibconfig ] ; then
- echo Running /usr/sbin/guile1.4-slibconfig
- /usr/sbin/guile1.4-slibconfig
+ echo guile1.4-slibconfig
+ guile1.4-slibconfig
fi
if [ -x /usr/bin/guile-1.6 -a -e /usr/share/guile/1.6/slib ] ; then
rm -f /usr/share/guile/1.6/slibcat
- /usr/bin/guile-1.6 -c "(use-modules (ice-9 slib)) (require 'new-catalog)"
+
+ guile-1.6 -c "(use-modules (ice-9 slib)) (require 'new-catalog)"
+
if [ -e /usr/share/guile/1.6/slibcat ] ; then
chmod 644 /usr/share/guile/1.6/slibcat
fi
@@ -25,15 +24,9 @@ fi
if [ -x /usr/bin/scm ] ; then
rm -f /usr/lib/scm/slibcat
- /usr/bin/scm -c "(require 'new-catalog)"
+ scm -c "(require 'new-catalog)"
+
if [ -e /usr/lib/scm/slibcat ] ; then
chmod 644 /usr/lib/scm/slibcat
fi
fi
-
-# doc base support
-if [ "$1" = configure ]; then
- if test -x /usr/sbin/install-docs >/dev/null 2>&1; then
- /usr/sbin/install-docs -i /usr/share/doc-base/slib
- fi
-fi