aboutsummaryrefslogtreecommitdiffstats
path: root/dbinterp.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /dbinterp.scm
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'dbinterp.scm')
-rw-r--r--dbinterp.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/dbinterp.scm b/dbinterp.scm
index 2bd4e20..3444fbb 100644
--- a/dbinterp.scm
+++ b/dbinterp.scm
@@ -17,12 +17,10 @@
;promotional, or sales literature without prior written consent in
;each case.
-(require 'rev4-optional-procedures) ; list-tail
-
;;; The procedures returned by MEMOIZE are not reentrant!
(define (dbinterp:memoize proc k)
(define recent (vector->list (make-vector k '(#f))))
- (let ((tailr (list-tail recent (+ -1 k))))
+ (let ((tailr (last-pair recent)))
(lambda args
(define asp (assoc args recent))
(if asp
@@ -35,8 +33,8 @@
;;@ This procedure works only for tables with a single primary key.
(define (interpolate-from-table table column)
- (define get (dbinterp:memoize (table 'get column) 3))
- (define prev (dbinterp:memoize (table 'isam-prev) 3))
+ (define get (table 'get column))
+ (define prev (table 'isam-prev))
(define next (table 'isam-next))
(dbinterp:memoize
(lambda (x)