aboutsummaryrefslogtreecommitdiffstats
path: root/daylight.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /daylight.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'daylight.scm')
-rw-r--r--daylight.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/daylight.scm b/daylight.scm
index 6c989b2..9151f99 100644
--- a/daylight.scm
+++ b/daylight.scm
@@ -245,17 +245,11 @@
(vector-set! data (quotient (- wl 380) 10)
(* (solCurve wl) tauR tauA tauO tauG tauWA))))))
-;;@body Returns (unnormalized) XYZ values for color of sunlight for a
-;;given @1 and @2.
-(define (sunlight-XYZ turbidity theta_s)
- (define spectrum (sunlight-spectrum turbidity theta_s))
- (and spectrum (spectrum->XYZ spectrum 380.e-9 780.e-9)))
-
;;@body Given @1 and @2, @0 returns the CIEXYZ triple for color of
;;sunlight scaled to be just inside the RGB709 gamut.
-(define (sunlight-CIEXYZ turbidity theta_s)
+(define (sunlight-chromaticity turbidity theta_s)
(define spectrum (sunlight-spectrum turbidity theta_s))
- (and spectrum (spectrum->CIEXYZ spectrum 380.e-9 780.e-9)))
+ (and spectrum (spectrum->chromaticity spectrum 380.e-9 780.e-9)))
;; Arguments and result in radians
(define (angle-between theta phi theta_s phi_s)