aboutsummaryrefslogtreecommitdiffstats
path: root/cvs.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /cvs.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'cvs.txi')
-rw-r--r--cvs.txi14
1 files changed, 13 insertions, 1 deletions
diff --git a/cvs.txi b/cvs.txi
index 0ff1656..fed8ba8 100644
--- a/cvs.txi
+++ b/cvs.txi
@@ -4,29 +4,41 @@ Returns a list of the local pathnames (with prefix @var{directory/}) of all
CVS controlled files in @var{directory/} and in @var{directory/}'s subdirectories.
@end defun
+
@defun cvs-directories directory/
Returns a list of all of @var{directory/} and all @var{directory/}'s CVS controlled
subdirectories.
@end defun
+
@defun cvs-root path/
Returns the (string) contents of @var{path/}CVS/Root;
or @code{(getenv "CVSROOT")} if Root doesn't exist.
@end defun
+
@defun cvs-repository directory/
Returns the (string) contents of @var{directory/}CVS/Root appended
with @var{directory/}CVS/Repository; or #f if @var{directory/}CVS/Repository
doesn't exist.
@end defun
+
@deffn {Procedure} cvs-set-root! new-root directory/
-Writes @var{new-root} to file CVS/Root of @var{directory/} and all its subdirectories.
+Writes @var{new-root} to file CVS/Root of @var{directory/}.
+@end deffn
+
+
+@deffn {Procedure} cvs-set-roots! new-root directory/
+
+Writes @var{new-root} to file CVS/Root of @var{directory/} and all its CVS subdirectories.
@end deffn
+
@defun cvs-vet directory/
Signals an error if CVS/Repository or CVS/Root files in @var{directory/} or any
subdirectory do not match.
@end defun
+