aboutsummaryrefslogtreecommitdiffstats
path: root/cvs.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /cvs.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'cvs.scm')
-rw-r--r--cvs.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/cvs.scm b/cvs.scm
index f1c853c..956178c 100644
--- a/cvs.scm
+++ b/cvs.scm
@@ -106,7 +106,7 @@
(else (slib:error 'mismatched root repos)))))))
;;@body
-;;Writes @1 to file CVS/Root of @2 and all its subdirectories.
+;;Writes @1 to file CVS/Root of @2.
(define (cvs-set-root! new-root directory/)
(define root (cvs-root directory/))
(define repos (cvs-repository directory/))
@@ -124,6 +124,12 @@
port))))
;;@body
+;;Writes @1 to file CVS/Root of @2 and all its CVS subdirectories.
+(define (cvs-set-roots! new-root directory/)
+ (for-each (lambda (dir/) (cvs-set-root! new-root dir/))
+ (cvs-directories directory/)))
+
+;;@body
;;Signals an error if CVS/Repository or CVS/Root files in @1 or any
;;subdirectory do not match.
(define (cvs-vet directory/)