aboutsummaryrefslogtreecommitdiffstats
path: root/comlist.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /comlist.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'comlist.scm')
-rw-r--r--comlist.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/comlist.scm b/comlist.scm
index 2e3a6ef..3ca909f 100644
--- a/comlist.scm
+++ b/comlist.scm
@@ -30,9 +30,9 @@
;;;@ From: hugh@ear.mit.edu (Hugh Secker-Walker)
(define (make-list k . init)
(set! init (if (pair? init) (car init)))
- (do ((k k (+ -1 k))
+ (do ((k (+ -1 k) (+ -1 k))
(result '() (cons init result)))
- ((<= k 0) result)))
+ ((negative? k) result)))
;@
(define (copy-list lst) (append lst '()))
;@