aboutsummaryrefslogtreecommitdiffstats
path: root/colornam.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /colornam.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'colornam.txi')
-rw-r--r--colornam.txi6
1 files changed, 6 insertions, 0 deletions
diff --git a/colornam.txi b/colornam.txi
index f72167b..bc70632 100644
--- a/colornam.txi
+++ b/colornam.txi
@@ -12,6 +12,7 @@ through the @code{grey} procedure:
Returns @code{(inexact->exact (round (* k 2.55)))}, the X11 color
grey@i{<k>}.
@end defun
+
@noindent
A color dictionary is a database table relating @dfn{canonical}
@cindex canonical
@@ -28,6 +29,7 @@ Returns a downcased copy of the string or symbol @var{name} with
@samp{_}, @samp{-}, and whitespace removed.
@end defun
+
@defun color-name->color name table1 table2 @dots{}
@@ -36,6 +38,7 @@ canonical form of @var{name} in @var{table1}, @var{table2}, @dots{} in order; re
color-string of the first matching record; #f otherwise.
@end defun
+
@defun color-dictionaries->lookup table1 table2 @dots{}
@@ -45,6 +48,7 @@ in @var{table1}, @var{table2}, @dots{}; returning the color-string of the first
record; and #f otherwise.
@end defun
+
@defun color-dictionary name rdb base-table-type
@@ -61,6 +65,7 @@ database file; and the symbol @var{name} a table therein. @code{color-dictionar
read-only table @var{name} in database @var{name} if it exists; #f otherwise.
@end defun
+
@defun load-color-dictionary name rdb base-table-type
@@ -73,3 +78,4 @@ to a lookup procedure for the color dictionary @var{name} in @var{rdb}.
The value returned by @code{load-color-dictionary} is unspecified.
@end defun
+