aboutsummaryrefslogtreecommitdiffstats
path: root/coerce.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /coerce.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'coerce.scm')
-rw-r--r--coerce.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/coerce.scm b/coerce.scm
index 7505f3f..0842c9e 100644
--- a/coerce.scm
+++ b/coerce.scm
@@ -17,11 +17,12 @@
;promotional, or sales literature without prior written consent in
;each case.
+(require-if 'compiling 'array)
+
;;@body
;;Returns a symbol name for the type of @1.
(define (type-of obj)
(cond
- ;;((null? obj) 'null)
((boolean? obj) 'boolean)
((char? obj) 'char)
((number? obj) 'number)
@@ -33,9 +34,8 @@
((eof-object? obj) 'eof-object)
((list? obj) 'list)
((pair? obj) 'pair)
- ((and (provided? 'array) (array? obj)) 'array)
- ((and (provided? 'record) (record? obj)) 'record)
((vector? obj) 'vector)
+ ((and (provided? 'array) (array? obj)) 'array)
(else '?)))
;;@body