aboutsummaryrefslogtreecommitdiffstats
path: root/chap.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /chap.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'chap.scm')
-rw-r--r--chap.scm47
1 files changed, 41 insertions, 6 deletions
diff --git a/chap.scm b/chap.scm
index 0d8f99f..1766720 100644
--- a/chap.scm
+++ b/chap.scm
@@ -1,5 +1,5 @@
;;;; "chap.scm" Chapter ordering -*-scheme-*-
-;;; Copyright 1992, 1993, 1994 Aubrey Jaffer
+;;; Copyright 1992, 1993, 1994, 2003 Aubrey Jaffer
;
;Permission to copy this software, to modify it, to redistribute it,
;to distribute modified versions, and to use it for any purpose is
@@ -8,7 +8,7 @@
;1. Any copy made of this software must include this copyright notice
;in full.
;
-;2. I have made no warrantee or representation that the operation of
+;2. I have made no warranty or representation that the operation of
;this software will be error-free, and I am under no obligation to
;provide any services, by way of maintenance, update, or otherwise.
;
@@ -22,6 +22,27 @@
;;; section of the string consists of consecutive numeric or
;;; consecutive aphabetic characters.
+
+;;@code{(require 'chapter-order)}
+;;@ftindex chapter-order
+;;
+;;The @samp{chap:} functions deal with strings which are ordered like
+;;chapter numbers (or letters) in a book. Each section of the string
+;;consists of consecutive numeric or consecutive aphabetic characters of
+;;like case.
+
+;;@args string1 string2
+;;Returns #t if the first non-matching run of alphabetic upper-case or
+;;the first non-matching run of alphabetic lower-case or the first
+;;non-matching run of numeric characters of @var{string1} is
+;;@code{string<?} than the corresponding non-matching run of
+;;characters of @var{string2}.
+;;
+;;@example
+;;(chap:string<? "a.9" "a.10") @result{} #t
+;;(chap:string<? "4c" "4aa") @result{} #t
+;;(chap:string<? "Revised^@{3.99@}" "Revised^@{4@}") @result{} #t
+;;@end example
(define (chap:string<? s1 s2)
(let ((l1 (string-length s1))
(l2 (string-length s2)))
@@ -78,6 +99,11 @@
(length-race (+ 1 i) ctype1 (char<? c1 c2)))
(else (char<? c1 c2)))))))
(delimited 0)))
+;;@body
+;;Implement the corresponding chapter-order predicates.
+(define (chap:string>? string1 string2) (chap:string<? string2 string1))
+(define (chap:string<=? string1 string2) (not (chap:string<? string2 string1)))
+(define (chap:string>=? string1 string2) (not (chap:string<? string1 string2)))
(define chap:char-incr (- (char->integer #\2) (char->integer #\1)))
@@ -120,6 +146,19 @@
s)
(else (slib:error "inc-string error" s p)))))
+;;@args string
+;;Returns the next string in the @emph{chapter order}. If @var{string}
+;;has no alphabetic or numeric characters,
+;;@code{(string-append @var{string} "0")} is returnd. The argument to
+;;chap:next-string will always be @code{chap:string<?} than the result.
+;;
+;;@example
+;;(chap:next-string "a.9") @result{} "a.10"
+;;(chap:next-string "4c") @result{} "4d"
+;;(chap:next-string "4z") @result{} "4aa"
+;;(chap:next-string "Revised^@{4@}") @result{} "Revised^@{5@}"
+;;
+;;@end example
(define (chap:next-string s)
(do ((i (+ -1 (string-length s)) (+ -1 i)))
((or (negative? i)
@@ -144,7 +183,3 @@
; (display " > ")
; (display s2)
; (newline)))))
-
-(define (chap:string>? s1 s2) (chap:string<? s2 s1))
-(define (chap:string>=? s1 s2) (not (chap:string<? s1 s2)))
-(define (chap:string<=? s1 s2) (not (chap:string<? s2 s1)))