aboutsummaryrefslogtreecommitdiffstats
path: root/byte.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /byte.scm
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'byte.scm')
-rw-r--r--byte.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/byte.scm b/byte.scm
index b7e12da..2d410bd 100644
--- a/byte.scm
+++ b/byte.scm
@@ -1,5 +1,5 @@
;;; "byte.scm" small integers, not necessarily chars.
-; Copyright (c) 2001, 2002, 2003 Aubrey Jaffer
+; Copyright (C) 2001, 2002, 2003 Aubrey Jaffer
;
;Permission to copy this software, to modify it, to redistribute it,
;to distribute modified versions, and to use it for any purpose is
@@ -17,6 +17,8 @@
;promotional, or sales literature without prior written consent in
;each case.
+(require 'rev4-optional-procedures) ; string-copy
+
;;@code{(require 'byte)}
;;@ftindex byte
;;
@@ -80,7 +82,7 @@
(define (bytes-reverse! bytes)
(do ((idx 0 (+ 1 idx))
(xdi (+ -1 (bytes-length bytes)) (+ -1 xdi)))
- ((>= idx xdi) bytes)
+ ((> idx xdi) bytes)
(let ((tmp (byte-ref bytes idx)))
(byte-set! bytes idx (byte-ref bytes xdi))
(byte-set! bytes xdi tmp))))