aboutsummaryrefslogtreecommitdiffstats
path: root/bigloo.init
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /bigloo.init
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'bigloo.init')
-rw-r--r--bigloo.init27
1 files changed, 27 insertions, 0 deletions
diff --git a/bigloo.init b/bigloo.init
index dfe8e2f..13ad86d 100644
--- a/bigloo.init
+++ b/bigloo.init
@@ -215,6 +215,33 @@
;;; OBJ->STRING returns strings with control characters.
;;(define (object->string x) (obj->string x))
+;; input-port-position port bigloo procedure
+;; output-port-position port bigloo procedure
+;;
+;; Returns the current position (a character number), in the port.
+;;
+;; set-input-port-position! port pos bigloo procedure
+;; set-output-port-position! port pos bigloo procedure
+;;
+;; These functions set the file position indicator for port. The new
+;; position, measured in bytes, is specified by pos. It is an error to
+;; seek a port that cannot be changed (for instance, a string or a
+;; console port). The result of these functions is unspecified. An error
+;; is raised if the position cannot be changed.
+
+;;@ (FILE-POSITION <port> . <k>)
+(define (file-position port . k)
+ (if (null? k)
+ ((if (output-port? port)
+ output-port-position
+ input-port-position)
+ port)
+ (apply
+ (if (output-port? port)
+ set-output-port-position!
+ set-input-port-position!)
+ port k)))
+
;;@ (OUTPUT-PORT-WIDTH <port>)
(define (output-port-width . arg) 79)