aboutsummaryrefslogtreecommitdiffstats
path: root/arraymap.txi
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2005-11-02 14:55:21 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:32 -0800
commit34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73 (patch)
tree1189d06a81277bcf8539b0260a69a19f6038effb /arraymap.txi
parent611b3db17894e5fdc0db3d49eaf6743d27b44233 (diff)
parent5145dd3aa0c02c9fc496d1432fc4410674206e1d (diff)
downloadslib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.tar.gz
slib-34c54a22ff7818bb8b38ef4d9c87dbbcb221ba73.zip
Import Debian changes 3a2-1debian/3a2-1
slib (3a2-1) unstable; urgency=low * New upstream release. * Acknowledge NMU. (Closes: #281809) * Makefile: Don't hack Makefile; use rules instead. * debian/rules: Set on make invocations: prefix, htmldir, TEXI2HTML. * debian/rules (clean): Clean more stuff here. * Makefile: Comment out old rule for $(htmldir)slib_toc.html. Instead, specify directly that the texi2html invocation produces that file. * debian/rules (binary-indep): Find web files in slib subdir. * debian/control (Build-Depends-Indep): Go back to using scm.
Diffstat (limited to 'arraymap.txi')
-rw-r--r--arraymap.txi10
1 files changed, 8 insertions, 2 deletions
diff --git a/arraymap.txi b/arraymap.txi
index f10ad65..2547eaf 100644
--- a/arraymap.txi
+++ b/arraymap.txi
@@ -12,6 +12,7 @@ as the corresponding element in @var{array0}. The value returned is
unspecified. The order of application is unspecified.
@end deffn
+
@defun array-map prototype proc array1 array2 @dots{}
@var{array2}, @dots{} must have the same number of dimensions as
@@ -23,12 +24,14 @@ new array of type @var{prototype}. The new array is returned. The
order of application is unspecified.
@end defun
+
@defun array-for-each proc array0 @dots{}
@var{proc} is applied to each tuple of elements of @var{array0} @dots{}
in row-major order. The value returned is unspecified.
@end defun
+
@defun array-indexes array
Returns an array of lists of indexes for @var{array} such that, if
@@ -37,6 +40,7 @@ Returns an array of lists of indexes for @var{array} such that, if
@var{li})).
@end defun
+
@deffn {Procedure} array-index-map! array proc
applies @var{proc} to the indices of each element of @var{array} in
@@ -46,7 +50,7 @@ returned and the order of application are unspecified.
One can implement @var{array-indexes} as
@example
(define (array-indexes array)
- (let ((ra (apply create-array '#() (array-shape array))))
+ (let ((ra (apply make-array '#() (array-dimensions array))))
(array-index-map! ra (lambda x x))
ra))
@end example
@@ -59,10 +63,12 @@ Another example:
@end example
@end deffn
-@deffn {Procedure} array-copy! source destination
+
+@deffn {Procedure} array:copy! destination source
Copies every element from vector or array @var{source} to the
corresponding element of @var{destination}. @var{destination} must
have the same rank as @var{source}, and be at least as large in each
dimension. The order of copying is unspecified.
@end deffn
+