aboutsummaryrefslogtreecommitdiffstats
path: root/array.scm
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /array.scm
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'array.scm')
-rw-r--r--array.scm106
1 files changed, 63 insertions, 43 deletions
diff --git a/array.scm b/array.scm
index ff05fd0..4cf93b3 100644
--- a/array.scm
+++ b/array.scm
@@ -400,96 +400,116 @@
((or (zero? num) (negative? n))
(zero? num))))))
-;;@args z
-;;@args
+;;@defun A:floC128b z
+;;@defunx A:floC128b
;;Returns an inexact 128.bit flonum complex uniform-array prototype.
+;;@end defun
(define A:floC128b (make-prototype-checker 'A:floC128b complex? vector))
-;;@args z
-;;@args
+;;@defun A:floC64b z
+;;@defunx A:floC64b
;;Returns an inexact 64.bit flonum complex uniform-array prototype.
+;;@end defun
(define A:floC64b (make-prototype-checker 'A:floC64b complex? vector))
-;;@args z
-;;@args
+;;@defun A:floC32b z
+;;@defunx A:floC32b
;;Returns an inexact 32.bit flonum complex uniform-array prototype.
+;;@end defun
(define A:floC32b (make-prototype-checker 'A:floC32b complex? vector))
-;;@args z
-;;@args
+;;@defun A:floC16b z
+;;@defunx A:floC16b
;;Returns an inexact 16.bit flonum complex uniform-array prototype.
+;;@end defun
(define A:floC16b (make-prototype-checker 'A:floC16b complex? vector))
-;;@args z
-;;@args
+;;@defun A:floR128b x
+;;@defunx A:floR128b
;;Returns an inexact 128.bit flonum real uniform-array prototype.
+;;@end defun
(define A:floR128b (make-prototype-checker 'A:floR128b real? vector))
-;;@args z
-;;@args
+;;@defun A:floR64b x
+;;@defunx A:floR64b
;;Returns an inexact 64.bit flonum real uniform-array prototype.
+;;@end defun
(define A:floR64b (make-prototype-checker 'A:floR64b real? vector))
-;;@args z
-;;@args
+;;@defun A:floR32b x
+;;@defunx A:floR32b
;;Returns an inexact 32.bit flonum real uniform-array prototype.
+;;@end defun
(define A:floR32b (make-prototype-checker 'A:floR32b real? vector))
-;;@args z
-;;@args
+;;@defun A:floR16b x
+;;@defunx A:floR16b
;;Returns an inexact 16.bit flonum real uniform-array prototype.
+;;@end defun
(define A:floR16b (make-prototype-checker 'A:floR16b real? vector))
-;;@args z
-;;@args
+;;@defun A:floR128d q
+;;@defunx A:floR128d
;;Returns an exact 128.bit decimal flonum rational uniform-array prototype.
-(define A:floR128b (make-prototype-checker 'A:floR128b real? vector))
-;;@args z
-;;@args
+;;@end defun
+(define A:floR128d (make-prototype-checker 'A:floR128d real? vector))
+;;@defun A:floR64d q
+;;@defunx A:floR64d
;;Returns an exact 64.bit decimal flonum rational uniform-array prototype.
-(define A:floR64b (make-prototype-checker 'A:floR64b real? vector))
-;;@args z
-;;@args
+;;@end defun
+(define A:floR64d (make-prototype-checker 'A:floR64d real? vector))
+;;@defun A:floR32d q
+;;@defunx A:floR32d
;;Returns an exact 32.bit decimal flonum rational uniform-array prototype.
-(define A:floR32b (make-prototype-checker 'A:floR32b real? vector))
+;;@end defun
+(define A:floR32d (make-prototype-checker 'A:floR32d real? vector))
-;;@args n
-;;@args
+;;@defun A:fixZ64b n
+;;@defunx A:fixZ64b
;;Returns an exact binary fixnum uniform-array prototype with at least
;;64 bits of precision.
+;;@end defun
(define A:fixZ64b (make-prototype-checker 'A:fixZ64b (integer-bytes?? -8) vector))
-;;@args n
-;;@args
+;;@defun A:fixZ32b n
+;;@defunx A:fixZ32b
;;Returns an exact binary fixnum uniform-array prototype with at least
;;32 bits of precision.
+;;@end defun
(define A:fixZ32b (make-prototype-checker 'A:fixZ32b (integer-bytes?? -4) vector))
-;;@args n
-;;@args
+;;@defun A:fixZ16b n
+;;@defunx A:fixZ16b
;;Returns an exact binary fixnum uniform-array prototype with at least
;;16 bits of precision.
+;;@end defun
(define A:fixZ16b (make-prototype-checker 'A:fixZ16b (integer-bytes?? -2) vector))
-;;@args n
-;;@args
+;;@defun A:fixZ8b n
+;;@defunx A:fixZ8b
;;Returns an exact binary fixnum uniform-array prototype with at least
;;8 bits of precision.
+;;@end defun
(define A:fixZ8b (make-prototype-checker 'A:fixZ8b (integer-bytes?? -1) vector))
-;;@args k
-;;@args
+;;@defun A:fixN64b k
+;;@defunx A:fixN64b
;;Returns an exact non-negative binary fixnum uniform-array prototype with at
;;least 64 bits of precision.
+;;@end defun
(define A:fixN64b (make-prototype-checker 'A:fixN64b (integer-bytes?? 8) vector))
-;;@args k
-;;@args
+;;@defun A:fixN32b k
+;;@defunx A:fixN32b
;;Returns an exact non-negative binary fixnum uniform-array prototype with at
;;least 32 bits of precision.
+;;@end defun
(define A:fixN32b (make-prototype-checker 'A:fixN32b (integer-bytes?? 4) vector))
-;;@args k
-;;@args
+;;@defun A:fixN16b k
+;;@defunx A:fixN16b
;;Returns an exact non-negative binary fixnum uniform-array prototype with at
;;least 16 bits of precision.
+;;@end defun
(define A:fixN16b (make-prototype-checker 'A:fixN16b (integer-bytes?? 2) vector))
-;;@args k
-;;@args
+;;@defun A:fixN8b k
+;;@defunx A:fixN8b
;;Returns an exact non-negative binary fixnum uniform-array prototype with at
;;least 8 bits of precision.
+;;@end defun
(define A:fixN8b (make-prototype-checker 'A:fixN8b (integer-bytes?? 1) vector))
-;;@args bool
-;;@args
+;;@defun A:bool bool
+;;@defunx A:bool
;;Returns a boolean uniform-array prototype.
+;;@end defun
(define A:bool (make-prototype-checker 'A:bool boolean? vector))