aboutsummaryrefslogtreecommitdiffstats
path: root/alistab.scm
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /alistab.scm
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.tar.gz
slib-e33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'alistab.scm')
-rw-r--r--alistab.scm33
1 files changed, 21 insertions, 12 deletions
diff --git a/alistab.scm b/alistab.scm
index e51bd26..e8999bf 100644
--- a/alistab.scm
+++ b/alistab.scm
@@ -8,7 +8,7 @@
;1. Any copy made of this software must include this copyright notice
;in full.
;
-;2. I have made no warrantee or representation that the operation of
+;2. I have made no warranty or representation that the operation of
;this software will be error-free, and I am under no obligation to
;provide any services, by way of maintenance, update, or otherwise.
;
@@ -23,7 +23,9 @@
;;; ROW is a list of non-primary VALUEs
(require 'common-list-functions)
-
+(require 'relational-database) ;for make-relational-system
+(require-if 'compiling 'sort)
+;@
(define alist-table
(let ((catalog-id 0)
(resources '*base-resources*)
@@ -42,13 +44,15 @@
(list resources (list 'free-id 1))))
(define (open-base infile writable)
- (and (or (input-port? infile) (file-exists? infile))
- (cons (if (input-port? infile) #f infile)
- ((lambda (fun)
- (if (input-port? infile)
- (fun infile)
- (call-with-input-file infile fun)))
- read))))
+ (define (reader port)
+ (cond ((eof-object? port) #f)
+ ((not (eqv? #\; (read-char port))) #f)
+ ((not (eqv? #\; (read-char port))) #f)
+ (else (cons (and (not (input-port? infile)) infile)
+ (read port)))))
+ (cond ((input-port? infile) (reader infile))
+ ((file-exists? infile) (call-with-input-file infile reader))
+ (else #f)))
(define (write-base lldb outfile)
((lambda (fun)
@@ -57,7 +61,8 @@
(else #f)))
(lambda (port)
(display (string-append
- ";;; \"" outfile "\" SLIB alist-table database -*-scheme-*-")
+ ";;; \"" outfile "\" SLIB " *SLIB-VERSION*
+ " alist-table database -*-scheme-*-")
port)
(newline port) (newline port)
(display "(" port) (newline port)
@@ -303,12 +308,12 @@
(define (supported-type? type)
(case type
- ((base-id atom integer boolean string symbol expression number) #t)
+ ((atom ordinal integer boolean string symbol expression number) #t)
(else #f)))
(define (supported-key-type? type)
(case type
- ((atom integer number symbol string) #t)
+ ((atom ordinal integer number symbol string) #t)
(else #f)))
;;make-table open-table remover assoc* make-assoc*
@@ -349,4 +354,8 @@
(else #f)))
))
+(set! *base-table-implementations*
+ (cons (list 'alist-table (make-relational-system alist-table))
+ *base-table-implementations*))
+
;; #f (trace-all "/home/jaffer/slib/alistab.scm") (untrace alist-table) (set! *qp-width* 333)