aboutsummaryrefslogtreecommitdiffstats
path: root/RScheme.init
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-28 16:25:32 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commitd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch)
treeb20b8bc02e854c4c86d39ee22a0638a8b06e01af /RScheme.init
parentedd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff)
parent64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff)
downloadslib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz
slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low * New upstream release. * slib.texi (Library Catalogs): Repeat change from 3a3-3. * Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1. * guile.init: (library-vicinity): Repeat change from 3a4-2. * debian/rules (binary-indep): Don't hide .init files in a separate subdirectory, thus conforming better to the usual slib practice. Put a symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'RScheme.init')
-rw-r--r--RScheme.init5
1 files changed, 4 insertions, 1 deletions
diff --git a/RScheme.init b/RScheme.init
index 4f80b41..87aacdb 100644
--- a/RScheme.init
+++ b/RScheme.init
@@ -48,7 +48,7 @@
;; Use this path if your scheme does not support GETENV
;; or if SCHEME_LIBRARY_PATH is not set.
(case (software-type)
- ((unix) "/usr/share/slib/")
+ ((unix) "/usr/lib/slib/")
((vms) "lib$scheme:")
((ms-dos) "C:\\SLIB\\")
(else "")))))
@@ -211,6 +211,9 @@
))
+;;@ (FILE-POSITION <port> . <k>)
+(define (file-position . args) #f)
+
;;; (OUTPUT-PORT-WIDTH <port>)
(define (output-port-width . arg) 79)